Clover-for-IDEA Installation Guide

Installing the plug-in

OpenClover currently supports IntelliJ IDEA 2024.3 through 2026.1; see Supported Platforms for the current range.

  1. Download the Clover-for-IDEA plug-in JAR.
  2. Launch IntelliJ IDEA.
  3. Go to 'File > Settings > Plugins' (Linux, Windows) or 'IDEA > Preferences > Plugins' (macOS).
  4. Click the gear icon and select 'Install Plugin from Disk...', then point to the downloaded JAR.
  5. Close and re-start IDEA.

You can now begin using Clover for IDEA.

Showing Clover tool bar

IDEA hides the tool bar by default. Click "View -> Toolbar" from the main menu to show Clover's buttons.

Known Issues

  • If you are using the Maven build tool, you should avoid using the same IntelliJ output directory as Maven does. As Maven uses the target/classes and target/test-classes directories, avoid specifying these ones. The clover.db location for IntelliJ should also be distinct from that used by Maven.

Uninstalling the Plugin

Uninstall it via 'File > Settings > Plugins' (Linux, Windows) or 'IDEA > Preferences > Plugins' (macOS). Just select the Clover IDEA Plugin from the list and click the gear icon, then 'Uninstall'. The removal will take place after you restart IDEA.